General Solaris Command


Shows the ethernet address arp table
# arp -a

Delete a stale ethernet entry for host xhost
# arp -d xhost

Reports disk space used in Kilobytes
# du -k

Reports only total disk space used in Kilobytes
# du -sk

Tells you how big the / files are in reverse order
# du -ad / | sort -nr

Mount an ISO 8660 CDROM
# /bin/mount -F hsfs -o ro /dev/sr0 /cdrom

Disk geometry and partitioning info
# prtvtoc /dev/rdsk/c0t0d0s2

Zero's out the file without breaking pipe
# cat /dev/null > filename

Make a mirror image of your boot disk
# dd if=/dev/rdsk/... of=/dev/rdsk/... bs=4096

Check a UFS filesystem
# fsck -F ufs /dev/rdsk/cxtxdxsx

Check a UFS filesystem with auto-answer "yes"
# fsck -F ufs -y /dev/rdsk/cxtxdxsx

Check using an alternate super block
# fsck -F ufs -o b=97472 /dev/rdsk/cxtxdxsx

Verify reconfigurable hardware resources
# cfgadm

Display kernel module information
# /usr/sbin/modinfo

Load a kernel module
# /usr/sbin/modload

Unload a kernel module
# /usr/sbin/modunload -i

Tuneable kernel parameters
# nm -x /dev/ksyms | grep OBJ | more

Show system kernal tunable details
# /usr/sbin/sysdef

Display Memory Size
# prtconf | grep "Memory size"

Displays number active established connections to localhost
# netstat -a | grep EST | wc -l

Network statistics for specific device
# netstat -k hme0

Show the TCP/IP network interfaces
# netstat -i

Displays routing information but bypasses hostname lookup
# netstat -rn

Show the state of all sockets
# netstat -a | more

Follow the route to the ipaddress
# traceroute

Show processes that are running from /var
# fuser -uc /var

Shows processes' current open files
# pfiles

An alternative for top command
# prstat -a

Displays CPU % usage for each process in ascending order
# /usr/ucb/ps -aux | more

Show all processes running
# ps -ef | more

Print the parent/child process 'tree' of a process
# /usr/proc/bin/ptree

Print the working directory of a process
# /usr/proc/bin/pwdx

Returns the process utilizing the most cpu and quits
# top -b 1

Watch all network packets on device ce0
# snoop -d ce0

Saves packets from device ce0 and between host1 and host2 to a file
# snoop -o /tmp/mylog -d ce0 host1 host2

Makes a 10 Megabyte swapfile in /export/disk
# mkfile -v 10m /export/disk1/myswap

List the amount of swap space available
# swap -s

Add a swapfile
# swap -a /export/disk1/swapfile

Deletes a swap device
# swap -d /dev/dsk/c0t0d0s4

List the current swap devices
# swap -l

Changes eeprom autoboot? setting to auto boot
# /usr/sbin/eeprom auto-boot? true

Set the system to perform diagnostics on the next reboot
# /usr/sbin/eeprom diagswitch? true

Check /etc/group file syntax
# /usr/sbin/grpck

Check /etc/passwd file syntax
# /usr/sbin/pwck

Clear host specific network configuration information
# /usr/sbin/sys-unconfig

Show eeprom parameters
# /usr/sbin/eeprom

Show system configuration details
# /usr/sbin/prtconf -vp

Display number of processors
# psrinfo | wc -l

Provides cumulative system report
# sar -A

Report use of file access system routines
# sar -a

Report CPU Utilization
# sar -u

Displays system information
# uname -a

Popular posts from this blog

Howto configure boot device order on ILOM

SAN Switch Config Command

Howto cstm on HP-UX